show ip bgp injected-paths



show ip bgp injected-paths To display all the injected paths in the BGP routing table, use the show ip bgp injected-paths command in EXEC mode.

show ip bgp injected-paths
Syntax Description: This command has no arguments or keywords. Command Modes EXEC Examples

show ip bgp



show ip bgp

To display entries in the Border Gateway Protocol (BGP) routing table, use the show ip bgp command in EXEC command.

show ip bgp [network] [network-mask] [longer-prefixes] [prefix-list prefix-list-name | route-map
route-map-name] [shorter prefixes mask-length]

Syntax

  1. network (Optional) Network number, entered to display a particular network in the BGP routing table.
  2. network-mask (Optional) Displays all BGP routes matching the address and mask pair.
  3. longer-prefixes (Optional) Displays the route and more specific routes.
  4. prefix-list | route-map (Optional) Displays selected routes from a BGP routing table based on the contents of a prefix list or route map.
  5. prefix-list-name | route-map-name (Optional) The name of the route map or prefix list that is specified for the above argument.
  6. shorter prefixes mask-length (Optional) Displays learned prefixes that are longer than the maximum length but shorter than the specified mask for the prefix.
Command Modes : EXEC

Examples: (Please Click for Clear View)










Related Commands
  • clear ip bgp Resets a BGP connection or session.
  • neighbor soft-reconfiguration Configures the Cisco IOS software to start storing updates.

bgp inject-map exist-map



bgp inject-map exist-map

To inject a more specific route into a Border Gateway Protocol (BGP) routing table, use the bgp inject-map exist-map command in address family or router configuration mode. To disable the conditional injection of a selected route, use the no form of this command.

bgp inject-map {inject-map-name} exist-map {exist-map-name}[copy-attributes]
no bgp inject-map {inject-map-name} exist-map {exist-map-name}[copy-attributes]

Syntax: inject-map-name
Description: Defines the prefixes that will be created and installed to the local BGP table.

Syntax: exist-map-name
Description: Specifies the prefix that the BGP speaker will track.


Syntax: copy-attributes
Description: (Optional) Configures the injected route to inherit the attributes of the aggregate route.

Defaults: The BGP Conditional Route Injection feature is not enabled by default.

Command Modes: Address family configuration, Router configuration

Usage Guidelines:
If the copy-attributes keyword is not specified when the bgp inject-map command is used, thecomponents will use the default attributes for locally originated routes. If the copy-attribute keyword is used, the components will inherit the same attributes as the aggregate route.

To enable conditional route injection, the exist-map must contain both the match ip address prefix-list and match ip route-source prefix-list match clauses in the route map paragraph.

Examples:

The following example configures the router for conditional route injection:

(config-router)# bgp inject-map map1 exist-map map2 copy-attributes

Related Commands:
  • ip prefix-list -> Displays information about a prefix list or prefix list entries.
  • neighbor remote-as -> Adds an entry to the BGP or multiprotocol BGP neighbor table.
  • route-map (IP) -> Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.
  • show ip bgp -> Displays entries in the BGP routing table.
  • show ip bgp injected-paths -> Displays injected paths in the BGP routing table.




BGP Configuration Examples



This following configuration example configures conditional route injection for the inject-map named ORIGINATE and the exist-map named LEARNED_PATH:

router bgp 109
bgp inject-map ORIGINATE exist-map LEARNED_PATH
!
route-map LEARNED_PATH permit 10
match ip address prefix-list ROUTE
match ip route-source prefix-list ROUTE_SOURCE
!
route-map ORIGINATE permit 10
set ip address prefix-list ORIGINATED_ROUTES
set community 14616:555 additive
!
ip prefix-list ROUTE permit 10.1.1.0/24
!
ip prefix-list ORIGINATED_ROUTES permit 10.1.1.0/25
ip prefix-list ORIGINATED_ROUTES permit 10.1.1.128/25
!
ip prefix-list ROUTE_SOURCE permit 10.2.1.1/32

BGP Troubleshooting Tips



The BGP Conditional Route Injection feature is based on the injection of a more specific prefix into theBGP routing table when a less specific prefix is present. If conditional route injection is not workingproperly, check the following:

If conditional route injection is configured but does not occur, check for the existence of the aggregate prefix in the BGP routing table. The existence (or not) of the tracked prefix in the BGP
routing table can be verified with the show ip bgp command.

If the aggregate prefix exists but conditional route injection does not occur, verify that the aggregate prefix is being received from the correct neighbor and the prefix list identifying that neighbor is a /32 match.

Verify the injection (or not) of the more specific prefix using the show ip bgp injected-paths command.

Verify that the prefix that is being injected is not outside of the scope of the aggregate prefix.

Ensure that the inject route map is configured with the set ip address command and not the match ip address command.

Monitoring and Maintaining BGP Conditional Route Injection

To display BGP conditional advertisement information, use the following commands in EXEC mode, as needed:

Command: Router# show ip bgp
Purpose: Displays entries in the BGP routing table.

Command: Router# show ip bgp injected-paths
Purpose: Displays paths in the BGP routing table that were conditionally injected.

Command: Router# show ip bgp neighbors
Purpose: Displays information about the TCP and BGP connections to neighbors.


Verifying BGP Conditional Route Injection



To verify that the BGP Conditional Route Injection feature is configured correctly, use the show ip bgp or show ip bgp injected-paths command.

The following sample output is similar to the output that will be displayed when the show ip bgp
command is entered:

Router# show ip bgp 172.16.0.0
BGP routing table entry for 172.16.0.0/8, version 13
Paths:(2 available, best #1, table Default-IP-Routing-Table)
Flag:0x200
Not advertised to any peer
Local, (injected path from 172.16.0.0/8)
10.0.0.2 from 10.0.0.2 (2.2.2.2)
Origin incomplete, localpref 100, valid, external, best
Community:957874231
200
10.0.0.2 from 10.0.0.2 (2.2.2.2)
Origin incomplete, metric 0, localpref 100, valid, external

The following sample output is similar to the output that will be displayed when the show ip bgp
injected-routes command is entered:

Router# show ip bgp injected-paths
BGP table version is 11, local router ID is 10.0.0.1
Status codes:s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes:i - IGP, e - EGP, ? - incomplete



NetworkNext HopMetricLocPrfWeightPath
*>172.16.0.010.0.0.2

0?
*>172.17.0.0/1610.0.0.2

0?

Configuring BGP Conditional Route Injection



The BGP Conditional Route Injection feature is supported by all platforms in Cisco IOS Release 12.2(14)S that support BGP:

• Cisco 7200 series
• Cisco 7400 series
• Cisco 7500 series

Determining Platform Support Through Cisco Feature Navigator Cisco IOS software is packaged in feature sets that support specific platforms. To get updated information regarding platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature. Cisco Feature Navigator is a web-based tool that enables you to determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image.

You can search by feature or release. Under the release section, you can compare releases side by side to display both the features unique to each software release and the features in common.

See the following section for configuration tasks for the BGP Conditional Route Injection feature. Each task in the list is identified as either required or optional.

• Configuring BGP Conditional Route Injection (required)
• Verifying BGP Conditional Route Injection (optional)

To configure the BGP Conditional Route Injection feature, use the following commands beginning in global configuration mode:


CommandPurpose
Step 1Router(config)# router bgp as-numberPlaces the router in router configuration mode, and configures the router to run a BGP process.
Step 2Router(config-router)# bgp inject-map ORIGINATE
exist-map LEARNED_PATH
Configures the inject-map named ORIGINATE and the exist-map named LEARNED_PATH for conditional route injection.
Step 3Router(config-router)# exitExits router configuration mode, and enters global configuration mode.
Step 4Router(config)# route-map LEARNED_PATH permit
sequence-number
Configures the route map named
LEARNED_PATH.
Step 5Router(config-route-map)# match ip address prefix-list
ROUTE
Specifies the aggregate route to which a more specific route will be injected.
Step 6Router(config-route-map# match ip route-source
prefix-list ROUTE_SOURCE
Configures the prefix list named
ROUTE_SOURCE to redistribute the source of the route.

Note: The route source is the neighbor address that is configured with the neighbor remote-as command. The tracked prefix must come from this neighbor in order for conditional route injection to occur.
Step 7Router(config-route-map)# exitExits route-map configuration mode, and enters global configuration mode.
Step 8Router(config)# route-map ORIGINATE permit 10Configures the route map named ORIGINATE.
Step 9Router(config-route-map)# set ip address prefix-list ORIGINATED_ROUTESSpecifies the routes to be injected.
Step 10Router(config-route-map)# set community community-attribute additiveConfigures the community attribute of the injected routes.
Step 11Router(config-route-map)# exitExits route-map configuration mode, and enters global configuration mode.
Step 12Router(config)# ip prefix-list ROUTE permit
10.1.1.0/24
Configures the prefix list named ROUTE to permit routes from network 10.1.1.0/24.
Step 13Router(config)# ip prefix-list ORIGINATED_ROUTES
permit 10.1.1.0/25
Configures the prefix list named
ORIGINATED_ROUTES to permit routes from network 10.1.1.0/25.
Step 14Router(config)# ip prefix-list ORIGINATED_ROUTES
permit 10.1.1.128/25
Configures the prefix list named
ORIGINATED_ROUTES to permit routes from network 10.1.1.0/25.
Step 15Router(config)# ip prefix-list ROUTE_SOURCE permit
10.2.1.1/32
Configures the prefix list named
ROUTE_SOURCE to permit routes from network 10.2.1.1/32.

Note: The route source prefix list must be configured with a /32 mask in order for conditional route injection to occur.
Note: To enable conditional route injection, the exist-map must contain both the match ip address prefix-list and match ip route-source prefix-list match clauses in the route map paragraph.

BGP Route Flap Dampening



Route dampening (introduced in Cisco IOS version 11.0) is a mechanism to minimize the instability caused by route flapping and oscillation over the network. To accomplish this, criteria are defined to identify poorly behaved routes. A route which is flapping gets a penalty for each flap (1000). As soon as the cumulative penalty reaches a predefined "suppress−limit", the advertisement of the route will be suppressed. The penalty will be exponentially decayed based on a preconfigured "half−time". Once the penalty decreases below a predefined "reuse−limit", the route advertisement will be un−suppressed.

Routes, external to an AS, learned via IBGP will not be dampened. This is to avoid the IBGP peers having higher penalty for routes external to the AS.

The penalty will be decayed at a granularity of 5 seconds and the routes will be un−suppressed at a granularity of 10 seconds. The dampening information is kept until the penalty becomes less than half of "reuse−limit" , at that point the information is purged from the router.

Initially, dampening will be off by default. This might change if there is a need to have this feature enabled by default. The following are the commands used to control route dampening:

  • bgp dampening (will turn on dampening)
  • no bgp dampening (will turn off dampening)
  • bgp dampening (will change the half−life−time)

A command that sets all parameters at the same time is:

  • bgp dampening
  • (range is 1−45 min, current default is 15 min)
  • (range is 1−20000, default is 750)
  • (range is 1−20000, default is 2000)
  • (maximum duration a route can be suppressed, range is 1−255, default is 4 times half−life−time)
RTB#
hostname RTB
interface Serial0
ip address 203.250.15.2 255.255.255.252
interface Serial1
ip address 192.208.10.6 255.255.255.252
router bgp 100
bgp dampening
network 203.250.15.0
neighbor 192.208.10.5 remote−as 300

RTD#
hostname RTD
interface Loopback0
ip address 192.208.10.174 255.255.255.192
interface Serial0/0
ip address 192.208.10.5 255.255.255.252
router bgp 300
network 192.208.10.0
neighbor 192.208.10.6 remote−as 100
RTB is configured for route dampening with default parameters. Assuming the EBGP link to RTD is stable, RTB's BGP table would look like this:

RTB#show ip bgp
BGP table version is 24, local router ID is 203.250.15.2 Status codes: s
suppressed, d damped, h history, * valid, > best, i − internal Origin
codes: i − IGP, e − EGP, ? − incomplete


NetworkNext HopMetricLocPrfWeightPath
*>192.208.10.0192.208.10.50
0300 i
*>203.250.15.00.0.0.00
32768i

In order to simulate a route flap, use clear ip bgp 192.208.10.6 on RTD. RTB's BGP table will look like this:

RTB#show ip bgp
BGP table version is 24, local router ID is 203.250.15.2 Status codes: s
suppressed, d damped, h history, * valid, > best, i − internal Origin
codes: i − IGP, e − EGP, ? − incomplete



NetworkNext HopMetricLocPrfWeightPath
h192.208.10.0192.208.10.50
0300 i
*>203.250.15.00.0.0.00
32768i

The BGP entry for 192.208.10.0 has been put in a "history" state. Which means that we do not have a best path to the route but information about the route flapping still exists.

RTB#show ip bgp 192.208.10.0
BGP routing table entry for 192.208.10.0 255.255.255.0, version 25
Paths: (1 available, no best path)
300 (history entry)
192.208.10.5 from 192.208.10.5 (192.208.10.174)
Origin IGP, metric 0, external
Dampinfo: penalty 910, flapped 1 times in 0:02:03
The route has been given a penalty for flapping but the penalty is still below the "suppress limit" (default is 2000). The route is not yet suppressed. If the route flaps few more times we will see the following:

RTB#show ip bgp
BGP table version is 32, local router ID is 203.250.15.2 Status codes:
s suppressed, d damped, h history, * valid, > best, i − internal Origin codes:
i − IGP, e − EGP, ? − incomplete


NetworkNext HopMetricLocPrfWeightPath
*d192.208.10.0192.208.10.50
0300 i
*>203.250.15.00.0.0.00
32768i

RTB#show ip bgp 192.208.10.0
BGP routing table entry for 192.208.10.0 255.255.255.0, version 32
Paths: (1 available, no best path)
300, (suppressed due to dampening)
192.208.10.5 from 192.208.10.5 (192.208.10.174)
Origin IGP, metric 0, valid, external
Dampinfo: penalty 2615, flapped 3 times in 0:05:18 , reuse in 0:27:00

The route has been dampened (suppressed). The route will be reused when the penalty reaches the "reuse value", in our case 750 (default).The dampening information will be purged when the penalty becomes less than half of the reuse−limit, in our case (750/2=375). The following are the commands used to show and clear flap statistics information:
  • show ip bgp flap−statistics (displays flap statistics for all the paths)
  • show ip bgp−flap−statistics regexp (displays flap statistics for all paths that match the regexp)
  • show ip bgp flap−statistics filter−list (displays flap statistics for all paths that pass the filter)
  • show ip bgp flap−statistics A.B.C.D m.m.m.m (displays flap statistics for a single entry)
  • show ip bgp flap−statistics A.B.C.D m.m.m.m longer−prefixes (displays flap statistics for more specific entries)
  • show ip bgp neighbor [dampened−routes] | [flap−statistics] (displays flap statistics for all paths from a neighbor)
  • clear ip bgp flap−statistics (clears flap statistics for all routes)
  • clear ip bgp flap−statistics regexp (clears flap statistics for all the paths that match the regexp)
  • clear ip bgp flap−statistics filter−list (clears flap statistics for all the paths that pass the filter)
  • clear ip bgp flap−statistics A.B.C.D m.m.m.m (clears flap statistics for a single entry)
  • clear ip bgp A.B.C.D flap−statistics (clears flap statistics for all paths from a neighbor)

RR and Conventional BGP Speakers






It is normal in an AS to have BGP speakers that do not understand the concept of route reflectors. We will call these routers conventional BGP speakers. The route reflector scheme will allow such conventional BGP speakers to coexist. These routers could be either members of a client group or a non−client group. This would allow easy and gradual migration from the current IBGP model to the route reflector model. One could start creating clusters by configuring a single router as RR and making other RRs and their clients normal IBGP peers. Then more clusters could be created gradually.

In the above diagram, RTD, RTE and RTF have the concept of route reflection. RTC, RTA and RTB are what we call conventional routers and cannot be configured as RRs. Normal IBGP mesh could be done between these routers and RTD. Later on, when we are ready to upgrade, RTC could be made a RR with clients RTA and RTB. Clients do not have to understand the route reflection scheme; it is only the RRs that would have to be upgraded.

The following is the configuration of RTD and RTC:

RTD#
router bgp 100
neighbor 6.6.6.6 remote−as 100
neighbor 6.6.6.6 route−reflector−client
neighbor 5.5.5.5 remote−as 100
neighbor 5.5.5.5 route−reflector−client
neighbor 3.3.3.3 remote−as 100
neighbor 2.2.2.2 remote−as 100
neighbor 1.1.1.1 remote−as 100
neighbor 13.13.13.13 remote−as 300

RTC#
router bgp 100
neighbor 4.4.4.4 remote−as 100
neighbor 2.2.2.2 remote−as 100
neighbor 1.1.1.1 remote−as 100
neighbor 14.14.14.14 remote−as 400

When we are ready to upgrade RTC and make it a RR, we would remove the IBGP full mesh and have RTA and RTB become clients of RTC.

Avoiding Looping of Routing Information

We have mentioned so far two attributes that are used to prevent potential information looping:

originator−id and cluster−list. Another means of controlling loops is to put more restrictions on the set clause of out−bound route−maps.

The set clause for out−bound route−maps does not affect routes reflected to IBGP peers.

More restrictions are also put on nexthop−self, which is a per neighbor configuration option. When used on RRs the nexthop−self will only affect the nexthop of EBGP learned routes because the nexthop of reflected routes should not be changed.

BGP Multiple RRs within a Cluster





Usually, a cluster of clients will have a single RR. In this case, the cluster will be identified by the router ID of the RR. In order to increase redundancy and avoid single points of failure, a cluster might have more than one RR. All RRs in the same cluster need to be configured with a 4 byte cluster−id so that a RR can recognize updates from RRs in the same cluster.

A cluster−list is a sequence of cluster−ids that the route has passed. When a RR reflects a route from its clients to non−clients outside of the cluster, it will append the local cluster−id to the cluster−list. If this update has an empty cluster−list the RR will create one. Using this attribute, a RR can identify if the routing information is looped back to the same cluster due to poor configuration. If the local cluster−id is found in the cluster−list, the advertisement will be ignored.

In the above diagram, RTD, RTE, RTF and RTH belong to one cluster with both RTD and RTH being RRs for the same cluster. Note the redundancy in that RTH has a fully meshed peering with all the RRs. In case RTD goes down, RTH will take its place. The following are the configuration of RTH, RTD, RTF and RTC:

RTH#
router bgp 100
neighbor 4.4.4.4 remote−as 100
neighbor 5.5.5.5 remote−as 100
neighbor 5.5.5.5 route−reflector−client
neighbor 6.6.6.6 remote−as 100
neighbor 6.6.6.6 route−reflector−client
neighbor 7.7.7.7 remote−as 100
neighbor 3.3.3.3 remote−as 100
neighbor 9.9.9.9 remote−as 300
bgp route−reflector 10 (This is the cluster−id)

RTD#
router bgp 100
neighbor 10.10.10.10 remote−as 100
neighbor 5.5.5.5 remote−as 100
neighbor 5.5.5.5 route−reflector−client
neighbor 6.6.6.6 remote−as 100
neighbor 6.6.6.6 route−reflector−client
neighbor 7.7.7.7 remote−as 100
neighbor 3.3.3.3 remote−as 100
neighbor 11.11.11.11 remote−as 400
bgp route−reflector 10 (This is the cluster−id)

RTF#
router bgp 100
neighbor 10.10.10.10 remote−as 100
neighbor 4.4.4.4 remote−as 100
neighbor 13.13.13.13 remote−as 500

RTC#
router bgp 100
neighbor 1.1.1.1 remote−as 100
neighbor 1.1.1.1 route−reflector−client
neighbor 2.2.2.2 remote−as 100
neighbor 2.2.2.2 route−reflector−client
neighbor 4.4.4.4 remote−as 100
neighbor 7.7.7.7 remote−as 100
neighbor 10.10.10.10 remote−as 100
neighbor 8.8.8.8 remote−as 200
Note that we did not need the cluster command for RTC because only one RR exists in that cluster. An important thing to note, is that peer−groups were not used in the above configuration. If the clients inside a cluster do not have direct IBGP peers among one another and they exchange updates through the RR, peer−goups should not be used. If peer groups were to be configured, then a potential withdrawal to the source of a route on the RR would be sent to all clients inside the cluster and could cause problems.

The router sub−command bgp client−to−client reflection is enabled by default on the RR. If BGP
client−to−client reflection were turned off on the RR and redundant BGP peering was made between the clients, then using peer groups would be alright.


BGP Route Reflectors



Another solution for the explosion of IBGP peering within an autonomous system is Route Reflectors (RR).

As demonstrated in the Internal BGP section, a BGP speaker will not advertise a route learned via another IBGP speaker to a third IBGP speaker. By relaxing this restriction a bit and by providing additional control, we can allow a router to advertise (reflect) IBGP learned routes to other IBGP speakers. This will reduce the number of IBGP peers within an AS.




In normal cases, a full IBGP mesh should be maintained between RTA, RTB and RTC within AS100. By utilizing the route reflector concept, RTC could be elected as a RR and have a partial IBGP peering with RTA and RTB. Peering between RTA and RTB is not needed because RTC will be a route reflector for the updates coming from RTA and RTB.
neighbor route−reflector−client
The router with the above command would be the RR and the neighbors pointed at would be the clients of that RR. In our example, RTC would be configured with the neighbor route−reflector−client command pointing at RTA and RTB's IP addresses. The combination of the RR and its clients is called a cluster. RTA, RTB and RTC above would form a cluster with a single RR within AS100.

Other IBGP peers of the RR that are not clients are called non−clients.


An autonomous system can have more than one route reflector; a RR would treat other RRs just like any other IBGP speaker. Other RRs could belong to the same cluster (client group) or to other clusters. In a simple configuration, the AS could be divided into multiple clusters, each RR will be configured with other RRs as non−client peers in a fully meshed topology. Clients should not peer with IBGP speakers outside their cluster.

Consider the above diagram. RTA, RTB and RTC form a single cluster with RTC being the RR. According to RTC, RTA and RTB are clients and anything else is a non−client. Remember that clients of an RR are pointed at using the neighbor route−reflector−client command. The same RTD is the RR for its clients RTE and RTF; RTG is a RR in a third cluster. Note that RTD, RTC and RTG are fully meshed but routers within a cluster are not. When a route is received by a RR, it will do the following depending on the peer type:

  1. Route from a non−client peer: reflect to all the clients within the cluster.
  2. Route from a client peer: reflect to all the non−client peers and also to the client peers.
  3. Route from an EBGP peer: send the update to all client and non−client peers.

The following is the relative BGP configuration of routers RTC, RTD and RTB:
RTC#
router bgp 100
neighbor 2.2.2.2 remote−as 100
neighbor 2.2.2.2 route−reflector−client
neighbor 1.1.1.1 remote−as 100
neighbor 1.1.1.1 route−reflector−client
neighbor 7.7.7.7 remote−as 100
neighbor 4.4.4.4 remote−as 100
neighbor 8.8.8.8 remote−as 200

RTB#
router bgp 100
neighbor 3.3.3.3 remote−as 100
neighbor 12.12.12.12 remote−as 300

RTD#
router bgp 100
neighbor 6.6.6.6 remote−as 100
neighbor 6.6.6.6 route−reflector−client
neighbor 5.5.5.5 remote−as 100
neighbor 5.5.5.5 route−reflector−client
neighbor 7.7.7.7 remote−as 100
neighbor 3.3.3.3 remote−as 100

As the IBGP learned routes are reflected, it is possible to have the routing information loop. The Route Reflector scheme has a few methods to avoid this:

  1. Originator−id: this is an optional, non transitive BGP attribute that is four bytes long and is created by a RR. This attribute will carry the router−id (RID) of the originator of the route in the local AS. Thus, due to poor configuration, if the routing information comes back to the originator, it will be ignored.
  2. Cluster−list: this will be discussed in the next section.

BGP Confederation



BGP confederation is implemented in order to reduce the IBGP mesh inside an AS. The trick is to divide an AS into multiple ASs and assign the whole group to a single confederation. Each AS by itself will have IBGP fully meshed and has connections to other AS's inside the confederation. Even though these ASs will have EBGP peers to ASs within the confederation, they exchange routing as if they were using IBGP; next hop, metric and local preference information are preserved. To the outside world, the confederation (the group of ASs) will look like a single AS.
To configure a BGP confederation use the following:
bgp confederation identifier autonomous−system
The confederation identifier will be the AS number of the confederation group. The group of ASs will look to the outside world as one AS with the AS number being the confederation identifier.

Peering within the confederation between multiple ASs is done via the following command:
bgp confederation peers autonomous−system [autonomous−system]
The following is an example of confederation:



Let us assume that you have an autonomous system 500 consisting of nine BGP speakers (other non BGP speakers exist also, but we are only interested in the BGP speakers that have EBGP connections to other ASs). If you want to make a full IBGP mesh inside AS500 then you would need nine peer connections for each router, 8 IBGP peers and one EBGP peer to external ASs.

By using confederation we can divide AS500 into multiple ASs: AS50, AS60 and AS70. We give the AS a confederation identifier of 500. The outside world will see only one AS500. For each AS50, AS60 and AS70 we define a full mesh of IBGP peers and we define the list of confederation peers using the bgp confederation peers command.

Let's look at a sample configuration of routers RTC, RTD and RTA. Note that RTA has no knowledge of ASs 50, 60 or 70. RTA has only knowledge of AS500.
RTC#
router bgp 50
bgp confederation identifier 500
bgp confederation peers 60 70
neighbor 128.213.10.1 remote−as 50 (IBGP connection within AS50)
neighbor 128.213.20.1 remote−as 50 (IBGP connection within AS50)
neighbor 129.210.11.1 remote−as 60 (BGP connection with confederation peer 60)
neighbor 135.212.14.1 remote−as 70 (BGP connection with confederation peer 70)
neighbor 5.5.5.5 remote−as 100 (EBGP connection to external AS100)

RTD#
router bgp 60
bgp confederation identifier 500
bgp confederation peers 50 70
neighbor 129.210.30.2 remote−as 60 (IBGP connection within AS60)
neighbor 128.213.30.1 remote−as 50(BGP connection with confederation peer 50)
neighbor 135.212.14.1 remote−as 70 (BGP connection with confederation peer 70)
neighbor 6.6.6.6 remote−as 600 (EBGP connection to external AS600)

RTA#
router bgp 100
neighbor 5.5.5.4 remote−as 500 (EBGP connection to confederation 500)


BGP CIDR



CIDR and Aggregate Addresses



One of the main enhancements of BGP4 over BGP3 is Classless Interdomain Routing (CIDR). CIDR or supernetting is a new way of looking at IP addresses. There is no notion of classes anymore (class A, B or C).

For example, network 192.213.0.0 which used to be an illegal class C network is now a legal supernet represented by 192.213.0.0/16 where the 16 is the number of bits in the subnet mask counting from the far left of the IP address. This is similar to 192.213.0.0 255.255.0.0.

Aggregates are used to minimize the size of routing tables. Aggregation is the process of combining the characteristics of several different routes in such a way that a single route can be advertised. In the example below, RTB is generating network 160.10.0.0. We will configure RTC to propagate a supernet of that route 160.0.0.0 to RTA.

RTB#
router bgp 200
neighbor 3.3.3.1 remote−as 300
network 160.10.0.0

#RTC
router bgp 300
neighbor 3.3.3.3 remote−as 200
neighbor 2.2.2.2 remote−as 100
network 170.10.0.0

aggregate−address 160.0.0.0 255.0.0.0
RTC will propagate the aggregate address 160.0.0.0 to RTA.

Aggregate Commands

There is a wide range of aggregate commands. It is important to understand how each one works in order to have the desired aggregation behavior.

The first command is the one used in the previous example:
aggregate−address address mask
This will advertise the prefix route, and all of the more specific routes. The command aggregate−address 160.0.0.0 will propagate an additional network 160.0.0.0 but will not prevent 160.10.0.0 from being also propagated to RTA. The outcome of this is that both networks 160.0.0.0 and 160.10.0.0 have been propagated to RTA. This is what we mean by advertising the prefix and the more specific route.

Please note that you can not aggregate an address if you do not have a more specific route of that address in the BGP routing table.

For example, RTB can not generate an aggregate for 160.0.0.0 if it does not have a more specific entry of 160.0.0.0 in its BGP table. The more specific route could have been injected into the BGP table via incoming updates from other ASs, from redistributing an IGP or static into BGP or via the network command (network 160.10.0.0).

In case we would like RTC to propagate network 160.0.0.0 only and NOT the more specific route then we would have to use the following:
aggregate−address address mask summary−only
This will a advertise the prefix only; all the more specific routes are suppressed.

The command aggregate 160.0.0.0 255.0.0.0 summary−only will propagate network 160.0.0.0 and will suppress the more specific route 160.10.0.0.

Please note that if we are aggregating a network that is injected into our BGP via the network statement (ex: network 160.10.0.0 on RTB) then the network entry is always injected into BGP updates even though we are using "the aggregate summary−only" command. The upcoming CIDR example discusses this situation.
aggregate−address address mask as−set
This advertises the prefix and the more specific routes but it includes as−set information in the path information of the routing updates.
aggregate 129.0.0.0 255.0.0.0 as−set
This command will be discussed in an example by itself in the following sections.

In case we would like to suppress more specific routes when doing the aggregation we can define a route map and apply it to the aggregates. This will allow us to be selective about which more specific routes to suppress.
aggregate−address address−mask suppress−map map−name
This advertises the prefix and the more specific routes but it suppresses advertisement according to a route−map. In the previous diagram, if we would like to aggregate 160.0.0.0 and suppress the more specific route 160.20.0.0 and allow 160.10.0.0 to be propagated, we can use the following route map:
route−map CHECK permit 10
match ip address 1
access−list 1 permit 160.20.0.0 0.0.255.255
access−list 1 deny 0.0.0.0 255.255.255.255
By definition of the suppress−map, any packets permitted by the access list would be suppressed from the updates.

Then we apply the route−map to the aggregate statement.
RTC#
router bgp 300
neighbor 3.3.3.3 remote−as 200
neighbor 2.2.2.2 remote−as 100
neighbor 2.2.2.2 remote−as 100
network 170.10.0.0
aggregate−address 160.0.0.0 255.0.0.0 suppress−map CHECK
Another variation is the:
aggregate−address address mask attribute−map map−name
This allows us to set the attributes (such as metric) when aggregates are sent out. The following route map when applied to the aggregate attribute−map command will set the origin of the aggregates to IGP.

route−map SETMETRIC
set origin igp
aggregate−address 160.0.0.0 255.0.0.0 attribute−map SETORIGIN
CIDR Example 1

Request: Allow RTB to advertise the prefix 160.0.0.0 and suppress all the more specific routes.

The problem here is that network 160.10.0.0 is local to AS200, meaning AS200 is the originator of 160.10.0.0. You cannot have RTB generate a prefix for 160.0.0.0 without generating an entry for 160.10.0.0 even if you use the aggregate summary−only command because RTB is the originator of 160.10.0.0. There are two solutions to this problem.

The first solution is to use a static route and redistribute it into BGP. The outcome is that RTB will advertise the aggregate with an origin of incomplete (?).

RTB#
router bgp 200
neighbor 3.3.3.1 remote−as 300
redistribute static (This will generate an update for 160.0.0.0 with the origin path as *incomplete*)
ip route 160.0.0.0 255.0.0.0 null0


In the second solution, in addition to the static route we add an entry for the network command. This has the same effect except that the origin of the update will be set to IGP.

RTB#
router bgp 200
network 160.0.0.0 mask 255.0.0.0 (this will mark the update with origin IGP)
neighbor 3.3.3.1 remote−as 300
redistribute static

ip route 160.0.0.0 255.0.0.0 null0

CIDR Example 2 (as−set)

AS−SETS are used in aggregation to reduce the size of the path information by listing the AS number only once, regardless of how many times it may have appeared in multiple paths that were aggregated. The as−set aggregate command is used in situations were aggregation of information causes loss of information regarding the path attribute. In the following example RTC is getting updates about 160.20.0.0 from RTA and updates about 160.10.0.0 from RTB. Suppose RTC wants to aggregate network 160.0.0.0/8 and send it to RTD. RTD would not know what the origin of that route is. By adding the aggregate as−set statement we force RTC to generate path information in the form of a set {}. All the path information is included in that set
irrespective of which path came first.

RTB#
router bgp 200
network 160.10.0.0
neighbor 3.3.3.1 remote−as 300
RTA#
router bgp 100
network 160.20.0.0
neighbor 2.2.2.1 remote−as 300

Case 1:

RTC does not have an as−set statement. RTC will send an update 160.0.0.0/8 to RTD with path information (300) as if the route has originated from AS300.

RTC#
router bgp 300
neighbor 3.3.3.3 remote−as 200
neighbor 2.2.2.2 remote−as 100
neighbor 4.4.4.4 remote−as 400
aggregate 160.0.0.0 255.0.0.0 summary−only
!−− this causes RTC to send RTD updates about 160.0.0.0/8 with no indication
!−− that 160.0.0.0 is actually coming from two different autonomous
!−− systems, this may create loops if RT4 has an entry back into AS100.

Case 2:

RTC#
router bgp 300
neighbor 3.3.3.3 remote−as 200
neighbor 2.2.2.2 remote−as 100
neighbor 4.4.4.4 remote−as 400
aggregate 160.0.0.0 255.0.0.0 summary−only
aggregate 160.0.0.0 255.0.0.0 as−set
!−− causes RTC to send RTD updates about 160.0.0.0/8 with an
!−− indication that 160.0.0.0 belongs to a set {100 200}.

BGP Peer Groups






A BGP peer group, is a group of BGP neighbors with the same update policies. Update policies are usually set by route maps, distribute−lists and filter−lists, etc. Instead of defining the same policies for each separate neighbor, we define a peer group name and we assign these policies to the peer group.

Members of the peer group inherit all of the configuration options of the peer group. Members can also be configured to override these options if these options do not affect outbound updates; you can only override options set on the inbound.

To define a peer group use the following:
neighbor peer−group−name peer−group
In the following example we will see how peer groups are applied to internal and external BGP neighbors.

RTC#
router bgp 300
neighbor internalmap peer−group
neighbor internalmap remote−as 300
neighbor internalmap route−map SETMETRIC out
neighbor internalmap filter−list 1 out
neighbor internalmap filter−list 2 in
neighbor 5.5.5.2 peer−group internalmap
neighbor 6.6.6.2 peer−group internalmap
neighbor 3.3.3.2 peer−group internalmap
neighbor 3.3.3.2 filter−list 3 in
In the above configuration, we have defined a peer group named internalmap and we have defined some policies for that group, such as a route map SETMETRIC to set the metric to 5 and two different filter lists 1 and 2. We have applied the peer group to all internal neighbors RTE, RTF and RTG. We have defined a separate filter−list 3 for neighbor RTE, and this will override filter−list 2 inside the peer group. Note that we could only override options that affect inbound updates.

Now, let us look at how we can use peer groups with external neighbors. In the same diagram we will configure RTC with a peer−group externalmap and we will apply it to external neighbors.
RTC#
router bgp 300
neighbor externalmap peer−group
neighbor externalmap route−map SETMETRIC
neighbor externalmap filter−list 1 out
neighbor externalmap filter−list 2 in
neighbor 2.2.2.2 remote−as 100
neighbor 2.2.2.2 peer−group externalmap
neighbor 4.4.4.2 remote−as 600
neighbor 4.4.4.2 peer−group externalmap
neighbor 1.1.1.2 remote−as 200
neighbor 1.1.1.2 peer−group externalmap
neighbor 1.1.1.2 filter−list 3 in
Note that in the above configs we have defined the remote−as statements outside of the peer group because we have to define different external ASs. Also we did an override for the inbound updates of neighbor 1.1.1.2 by assigning filter−list 3.

BGP Neighbors



BGP Neighbors and Route Maps



The neighbor command can be used in conjunction with route maps to perform either filtering or parameter setting on incoming and outgoing updates.

Route maps associated with the neighbor statement have no affect on incoming updates when matching based on the IP address:

neighbor ip−address route−map route−map−name

Assume in the above diagram we want RTC to learn from AS200 about networks that are local to AS200 and nothing else. Also, we want to set the weight on the accepted routes to 20. We can achieve this with a combination of neighbor and as−path access lists.

RTC#
router bgp 300
network 170.10.0.0
neighbor 3.3.3.3 remote−as 200
neighbor 3.3.3.3 route−map stamp in
route−map stamp
match as−path 1
set weight 20
ip as−path access−list 1 permit ^200$

Any updates that originate from AS200 have a path information that starts with 200 and ends with 200 and will be permitted. Any other updates will be dropped.

Assume that we want the following:
  • Updates originating from AS200 to be accepted with weight 20.
  • Updates originating from AS400 to be dropped.
  • Other updates to have a weight of 10.
RTC#
router bgp 300
network 170.10.0.0
neighbor 3.3.3.3 remote−as 200
neighbor 3.3.3.3 route−map stamp in
route−map stamp permit 10
match as−path 1
set weight 20
route−map stamp permit 20
match as−path 2
set weight 10
ip as−path access−list 1 permit ^200$
ip as−path access−list 2 permit ^200 600 .*

The above statement will set a weight of 20 for updates that are local to AS200, and will set a weight of 10 for updates that are behind AS400 and will drop updates coming from AS400.

Use of set as−path prepend Command

In some situations we are forced to manipulate the path information in order to manipulate the BGP decision process. The command that is used with a route map is:
set as−path prepend ...
Suppose in the above diagram that RTC is advertising its own network 170.10.0.0 to two different ASs:

AS100 and AS200. When the information is propagated to AS600, the routers in AS600 will have network reachability information about 150.10.0.0 via two different routes, the first route is via AS100 with PATH (100, 300) and the second one is via AS400 with PATH (400, 200,300). Assuming that all other attributes are the same AS600 will pick the shortest path and will choose the route via AS100.

AS300 will be getting all its traffic via AS100. If we want to influence this decision from the AS300 end we can make the PATH through AS100 look like it is longer than the PATH going through AS400. We can do this by prepending autonomous system numbers to the existing path info advertised to AS100. A common practice is to repeat our own AS number using the following:
RTC#
router bgp 300
network 170.10.0.0
neighbor 2.2.2.2 remote−as 100
neighbor 2.2.2.2 route−map SETPATH out
route−map SETPATH
set as−path prepend 300 300
Because of the above configuration, AS600 will receive updates about 170.10.0.0 via AS100 with a PATH information of: (100, 300, 300, 300) which is longer than (400, 200, 300) received from AS100.


BGP AS−Regular Expression



A regular expression is a pattern to match against an input string. By building a regular expression we specify a string that input must match. In case of BGP we are specifying a string consisting of path information that an input should match.

In the previous example we specified the string ^200$ and wanted path information coming inside updates to match it in order to perform a decision.

The regular expression is composed of the following:

Range

A range is a sequence of characters contained within left and right square brackets. ex: [abcd]

Atom

An atom is a single character, such as the following:

. (Matches any single character)
^ (Matches the beginning of the input string)
$ (Matches the end of the input string)
\ (Matches the character)
− (Matches a comma (,), left brace ({), right brace (}), the beginning of the input string, the end of the input string, or a space.

Piece

A piece is an atom followed by one of the following symbols:

* (Matches 0 or more sequences of the atom)
+ (Matches 1 or more sequences of the atom)
? (Matches the atom or the null string)

Branch

A branch is a 0 or more concatenated pieces.

Examples of regular expressions follow:

a* (Any occurrence of the letter "a", including none)
a+ ( At least one occurrence of the letter "a" should be present)
ab?a (This matches "aa" or "aba")
_100_ (Via AS100)
^100$ (Origin AS100)
^100 .* (Coming from AS100)
^$ (Originated from this AS)

BGP Community Filtering



We would like RTB above to set the community attribute to the BGP routes it is advertising such that RTC would not propagate these routes to its external peers. The no−export community attribute is used:

RTB#
router bgp 200
network 160.10.0.0
neighbor 3.3.3.1 remote−as 300
neighbor 3.3.3.1 send−community
neighbor 3.3.3.1 route−map setcommunity out
route−map setcommunity
match ip address 1
set community no−export
access−list 1 permit 0.0.0.0 255.255.255.255

Note that we have used the route−map setcommunity command in order to set the community to no−export. Note also that we had to use the neighbor send−community command in order to send this attribute to RTC.

When RTC gets the updates with the attribute no−export, it will not propagate them to its external peer RTA.

In the example below, RTB has set the community attribute to 100 200 additive. The value 100 200 will be added to any existing community value before being sent to RTC.

RTB#
router bgp 200
network 160.10.0.0
neighbor 3.3.3.1 remote−as 300
neighbor 3.3.3.1 send−community
neighbor 3.3.3.1 route−map setcommunity out

route−map setcommunity
match ip address 2
set community 100 200 additive
access−list 2 permit 0.0.0.0 255.255.255.255

A community list is a group of communities that we use in a match clause of a route map which allows us to do filtering or setting attributes based on different lists of community numbers.
ip community−list community−list−number {permit|deny} community−number
For example we can define the following route map, match−on−community:

route−map match−on−community
match community 10 (10 is the community−list number)
set weight 20
ip community−list 10 permit 200 300
!−− 200 300 is the community number
We can use the above in order to filter or set certain parameters like weight and metric based on the community value in certain updates. In example two above, RTB was sending updates to RTC with a community of 100 200. If RTC wants to set the weight based on those values we could do the following:

RTC#
router bgp 300
neighbor 3.3.3.3 remote−as 200
neighbor 3.3.3.3 route−map check−community in
route−map check−community permit 10
match community 1
set weight 20
route−map check−community permit 20
match community 2 exact
set weight 10
route−map check−community permit 30
match community 3
ip community−list 1 permit 100
ip community−list 2 permit 200
ip community−list 3 permit internet
In the above example, any route that has 100 in its community attribute will match list 1 and will have the weight set to 20. Any route that has only 200 as community will match list 2 and will have weight 20. The keyword exact states that community should consist of 200 only and nothing else. The last community list is here to make sure that other updates are not dropped. Remember that anything that does not match, will be dropped by default. The keyword internet means all routes because all routes are members of the internet community.

BGP Filtering



Sending and receiving BGP updates can be controlled by using a number of different filtering methods. BGP updates can be filtered based on route information, on path information or on communities. All methods will achieve the same results, choosing one over the other depends on the specific network configuration.

Route Filtering



In order to restrict the routing information that the router learns or advertises, you can filter BGP based on routing updates to or from a particular neighbor. In order to achieve this, an access−list is defined and applied to the updates to or from a neighbor. Use the following command in the router configuration mode:
neighbor {ip−address|peer−group−name} distribute−list access−list−number {in | out}

In the following example, RTB is originating network 160.10.0.0 and sending it to RTC. If RTC wanted to stop those updates from propagating to AS100, we would have to apply an access−list to filter those updates and apply it when talking to RTA:

RTC#
router bgp 300
network 170.10.0.0
neighbor 3.3.3.3 remote−as 200
neighbor 2.2.2.2 remote−as 100
neighbor 2.2.2.2 distribute−list 1 out
access−list 1 deny 160.10.0.0 0.0.255.255
access−list 1 permit 0.0.0.0 255.255.255.255
!−− filter out all routing updates about 160.10.x.x

Using access−lists is a bit tricky when you are dealing with supernets that might cause some conflicts.

Assume in the above example that RTB has different subnets of 160.10.X.X and our goal is to filter updates and advertise only 160.0.0.0/8 (this notation means that we are using 8 bits of subnet mask starting from the far left of the IP address; this is equivalent to 160.0.0.0 255.0.0.0).

The command access−list 1 permit 160.0.0.0 0.255.255.255 permits 160.0.0.0/8,160.0.0.0/9 and so on. In order to restrict the update to only 160.0.0.0/8 we have to use an extended access list of the following format:

access−list 101 160.0.0.0 0.255.255.255 255.0.0.0 0.0.0.0. This list permits 160.0.0.0/8 only.

Another type of filtering is path filtering, which is described in the next section.

Path Filtering



You can specify an access list on both incoming and outgoing updates based on the BGP autonomous system paths information. In the above figure we can block updates about 160.10.0.0 from going to AS100 by defining an access list on RTC that prevents any updates that have originated from AS200 from being sent to AS100. To do this use the following statements.

ip as−path access−list access−list−number {permit|deny} as−regular−expression
neighbor {ip−address|peer−group−name} filter−list access−list−number {in|out}

The following example stops RTC from sending RTA updates about 160.10.0.0

RTC#
router bgp 300
neighbor 3.3.3.3 remote−as 200
neighbor 2.2.2.2 remote−as 100
neighbor 2.2.2.2 filter−list 1 out
!−− the 1 is the access list number below
ip as−path access−list 1 deny ^200$
ip as−path access−list 1 permit .*


In the above example, access−list 1 states: deny any updates with path information that start with 200 (^) and end with 200 ($). The ^200$ is called a regular expression, with ^ meaning "starts with" and $ meaning "ends with". Since RTB sends updates about 160.10.0.0 with path information starting with 200 and ending with 200, this update matches the access list and will be denied.

The .* is another regular expression with the period meaning "any character" and the * meaning "the repetition of that character". So .* is actually any path information, which is needed to permit all other updates to be sent.

What would happen if instead of using ^200$ we have used ^200? If you have an AS400 (see figure above), updates originated by AS400 will have path information of the form (200, 400) with 200 being first and 400 being last. Those updates will match the access list ^200 because they start with 200 and will be prevented from being sent to RTA which is not the required behavior.

A good way to check whether we have implemented the correct regular expression is to use the show ip bgp regexp regular expression> command. This shows all the paths that have matched the configured regular expression.

BGP Backdoor Attribute






Consider the above diagram, RTA and RTC are running EBGP, and RTB and RTC are running EBGP. RTA and RTB are running some kind of IGP (RIP, IGRP, etc.). By definition, EBGP updates have a distance of 20 which is lower than the IGP distances. Default distance is 120 for RIP, 100 for IGRP, 90 for EIGRP and 110 for OSPF.

RTA will receive updates about 160.10.0.0 via two routing protocols:

EBGP with a distance of 20 and IGP with a distance higher than 20.

By default, BGP has the following distances, but that could be changed by the distance command:
distance bgp external−distance internal−distance local−distance
external−distance:20
internal−distance:200
local−distance:200

RTA will pick EBGP via RTC because of the lower distance.

If we want RTA to learn about 160.10.0.0 via RTB (IGP), then we have two options:
  • Change EBGP's external distance or IGP's distance, which is not recommended.
  • Use BGP backdoor.
BGP backdoor makes the IGP route the preferred route.

Use the following network address backdoor command.

The configured network is the network that we would like to reach via IGP. For BGP this network will be treated as a locally assigned network except it will not be advertised in BGP updates.

RTA#
router eigrp 10
network 160.10.0.0
router bgp 100
neighbor 2.2.2.1 remote−as 300
network 160.10.0.0 backdoor

Network 160.10.0.0 is treated as a local entry, but is not advertised as a normal network entry.

RTA learns 160.10.0.0 from RTB via EIGRP with distance 90, and also learns it from RTC via EBGP with distance 20. Normally EBGP is preferred, but because of the backdoor command EIGRP is preferred.

BGP Weight Attribute



BGP Weight Attribute




The weight attribute is a Cisco defined attribute. The weight is used for a best path selection process. The weight is assigned locally to the router. It is a value that only makes sense to the specific router and which is not propagated or carried through any of the route updates. A weight can be a number from 0 to 65535. Paths that the router originates have a weight of 32768 by default and other paths have a weight of zero.

Routes with a higher weight are preferred when multiple routes exist to the same destination. Let us study the above example. RTA has learned about network 175.10.0.0 from AS4 and will propagate the update to RTC. RTB has also learned about network 175.10.0.0 from AS4 and will propagate it to RTC. RTC has now two ways for reaching 175.10.0.0 and has to decide which way to go. If on RTC we can set the weight of the updates coming from RTA to be higher than the weight of updates coming from RTB, then we will force RTC to use RTA as a next hop to reach 175.10.0.0. This is achieved by using multiple methods:

  • Using the neighbor command: neighbor {ip−address|peer−group} weight weight.
  • Using AS path access−lists: ip as−path access−list access−list−number {permit|deny} as−regular−expression neighbor ip−address filter−list access−list−number weight weight.
  • Using route−maps.
RTC#
router bgp 300
neighbor 1.1.1.1 remote−as 100
neighbor 1.1.1.1 weight 200
!−− route to 175.10.0.0 from RTA has 200 weight
neighbor 2.2.2.2 remote−as 200
neighbor 2.2.2.2 weight 100
!−− route to 175.10.0.0 from RTB will have 100 weight

Routes with higher weight are preferred when multiple routes exist to the same destination. RTA is preferred as the next hop.

The same outcome can be achieved using IP as−path and filter lists.

RTC#
router bgp 300
neighbor 1.1.1.1 remote−as 100
neighbor 1.1.1.1 filter−list 5 weight 200
neighbor 2.2.2.2 remote−as 200
neighbor 2.2.2.2 filter−list 6 weight 100
...
ip as−path access−list 5 permit ^100$
!−− this only permits path 100
ip as−path access−list 6 permit ^200$
...
The same outcome as above can be achieved by using routemaps.
RTC#
router bgp 300
neighbor 1.1.1.1 remote−as 100
neighbor 1.1.1.1 route−map setweightin in
neighbor 2.2.2.2 remote−as 200
neighbor 2.2.2.2 route−map setweightin in
...
ip as−path access−list 5 permit ^100$
...
route−map setweightin permit 10
match as−path 5
set weight 200
!−− anything that applies to access−list 5, such as packets from AS100, have weight 200
route−map setweightin permit 20
set weight 100
!−− anything else would have weight 100





BGP Community Attribute



Community Attribute

The community attribute is a transitive, optional attribute in the range 0 to 4,294,967,200. The community attribute is a way to group destinations in a certain community and apply routing decisions (accept, prefer, redistribute, etc.) according to those communities.

We can use route maps to set the community attributes. The route map set command has the following syntax:

set community community−number [additive]

A few predefined well known communities (community−number) are:
  • no−export (Do not advertise to EBGP peers)
  • no−advertise (Do not advertise this route to any peer)
  • internet (Advertise this route to the internet community, any router belongs to it)
An example of route maps where community is set is:
route−map communitymap
match ip address 1
set community no−advertise
or
route−map setcommunity
match as−path 1
set community 200 additive
If the additive keyword is not set, 200 replaces any old community that already exits; if we use the keyword additive then the 200 is added to the community. Even if we set the community attribute, this attribute is not sent to neighbors by default. In order to send the attribute to our neighbor we have to use the following:
neighbor {ip−address|peer−group−name} send−community

Here's an example:

RTA#
router bgp 100
neighbor 3.3.3.3 remote−as 300
neighbor 3.3.3.3 send−community
neighbor 3.3.3.3 route−map setcommunity out





BGP Metric Attribute



Metric Attribute




The metric attribute which is also called Multi_exit_discriminator, MED (BGP4) or Inter−As (BGP3) is a hint to external neighbors about the preferred path into an AS. This is a dynamic way to influence another AS on which way to choose in order to reach a certain route given that we have multiple entry points into that AS. A lower value of a metric is more preferred.

Unlike local preference, metric is exchanged between ASs. A metric is carried into an AS but does not leave the AS. When an update enters the AS with a certain metric, that metric is used for decision making inside the AS. When the same update is passed on to a third AS, that metric will be set back to 0 as shown in the above diagram. The Metric default value is 0.

Unless otherwise specified, a router will compare metrics for paths from neighbors in the same AS. In order for the router to compare metrics from neighbors coming from different ASs the special configuration command "bgp always−compare−med" should be configured on the router.

In the above diagram, AS100 is getting information about network 180.10.0.0 via three different routers: RTC, RTD and RTB. RTC and RTD are in AS300 and RTB is in AS400.

Assume that we have set the metric coming from RTC to 120, the metric coming from RTD to 200 and the metric coming from RTB to 50. Given that by default a router compares metrics coming from neighbors in the same AS, RTA can only compare the metric coming from RTC to the metric coming from RTD and will pick RTC as the best next hop because 120 is less than 200. When RTA gets an update from RTB with metric 50, he can not compare it to 120 because RTC and RTB are in different ASs (RTA has to choose based on some other attributes).

In order to force RTA to compare the metrics we have to add bgp always−compare−med to RTA. This is illustrated in the configs below:

RTA#
router bgp 100
neighbor 2.2.2.1 remote−as 300
neighbor 3.3.3.3 remote−as 300
neighbor 4.4.4.3 remote−as 400
....

RTC#
router bgp 300
neighbor 2.2.2.2 remote−as 100
neighbor 2.2.2.2 route−map setmetricout out
neighbor 1.1.1.2 remote−as 300
route−map setmetricout permit 10
set metric 120

RTD#
router bgp 300
neighbor 3.3.3.2 remote−as 100
neighbor 3.3.3.2 route−map setmetricout out
neighbor 1.1.1.1 remote−as 300
route−map setmetricout permit 10
set metric 200

RTB#
router bgp 400
neighbor 4.4.4.4 remote−as 100
neighbor 4.4.4.4 route−map setmetricout out
route−map setmetricout permit 10
set metric 50


With the above configs, RTA will pick RTC as next hop, considering all other attributes are the same. In order to have RTB included in the metric comparison, we have to configure RTA as follows:

RTA#
router bgp 100
neighbor 2.2.21 remote−as 300
neighbor 3.3.3.3 remote−as 300
neighbor 4.4.4.3 remote−as 400
bgp always−compare−med


In this case RTA will pick RTB as the best next hop in order to reach network 180.10.0.0.
Metric can also be set while redistributing routes into BGP using the default−metric number command.

Assume in the above example that RTB is injecting a network via static into AS100 then the following configs:

RTB#
router bgp 400
redistribute static
default−metric 50
ip route 180.10.0.0 255.255.0.0 null 0
!−− Causes RTB to send out 180.10.0.0 with a metric of 50



BGP Local Preference Attribute



Local Preference Attribute



Local preference is an indication to the AS about which path is preferred to exit the AS in order to reach a certain network. A path with a higher local preference is more preferred. The default value for local preference is 100.

Unlike the weight attribute which is only relevant to the local router, local preference is an attribute that is exchanged among routers in the same AS.

Local preference is set via the bgp default local−preference value> command or with route−maps as will be demonstrated in the following example:

The bgp default local−preference command will set the local preference on the updates out of the router going to peers in the same AS. In the above diagram, AS256 is receiving updates about 170.10.0.0 from two different sides of the organization. Local preference will help us determine which way to exit AS256 in order to reach that network. Let us assume that RTD is the preferred exit point. The following configuration will set the local preference for updates coming from AS300 to 200 and those coming from AS100 to 150.

RTC#
router bgp 256
neighbor 1.1.1.1 remote−as 100
neighbor 128.213.11.2 remote−as 256
bgp default local−preference 150

RTD#
router bgp 256
neighbor 3.3.3.4 remote−as 300
neighbor 128.213.11.1 remote−as 256
bgp default local−preference 200

In the above configuration RTC will set the local preference of all updates to 150. The same RTD
will set the local preference of all updates to 200. Since local preference is exchanged within AS256, both RTC and RTD will realize that network 170.10.0.0 has a higher local preference when coming from AS300 rather than when coming from AS100. All traffic in AS256 addressed to that network will be sent to RTD as an exit point.

More flexibility is provided by using route maps. In the above example, all updates received by RTD will be tagged with local preference 200 when they reach RTD. This means that updates coming from AS34 will also be tagged with the local preference of 200. This might not be needed. This is why we can use route maps to specify what specific updates need to be tagged with a specific local preference as shown below:

RTD#
router bgp 256
neighbor 3.3.3.4 remote−as 300
neighbor 3.3.3.4 route−map setlocalin in
neighbor 128.213.11.1 remote−as 256
....
ip as−path access−list 7 permit ^300$
...
route−map setlocalin permit 10
match as−path 7
set local−preference 400
route−map setlocalin permit 20
set local−preference 150

With this configuration, any update coming from AS300 will be set with a local preference of 200. Any other updates such as those coming from AS34 will be set with a value of 150.


BGP Synchronization





Before we discuss synchronization let us look at the following scenario. RTC in AS300 is sending updates about 170.10.0.0. RTA and RTB are running IBGP, so RTB will get the update and will be able to reach 170.10.0.0 via next hop 2.2.2.1 (remember that the next hop is carried via IBGP). In order to reach the next hop, RTB will have to send the traffic to RTE.

Assume that RTA has not redistributed network 170.10.0.0 into IGP, so at this point RTE has no idea that 170.10.0.0 even exists.

If RTB starts advertising to AS400 that he can reach 170.10.0.0 then traffic coming from RTD to RTB with destination 170.10.0.0 will flow in and get dropped at RTE.

Synchronization states: If your autonomous system is passing traffic from another AS to a third AS, BGP should not advertise a route before all routers in your AS have learned about the route via IGP.

BGP will wait until IGP has propagated the route within the AS and then will advertise it to external peers. This is called synchronization.

In the above example, RTB will wait to hear about 170.10.0.0 via IGP before it starts sending the update to RTD. We can fool RTB into thinking that IGP has propagated the information by adding a static route in RTB pointing to 170.10.0.0. Care should be taken to make sure that other routers can reach 170.10.0.0 otherwise we will have a problem reaching that network.

Disabling Synchronization

In some cases you do not need synchronization. If you will not be passing traffic from a different autonomous system through your AS, or if all routers in your AS will be running BGP, you can disable synchronization. Disabling this feature can allow you to carry fewer routes in your IGP and allow BGP to converge more quickly.

Disabling synchronization is not automatic, if you have all your routers in the AS running BGP and you are not running any IGP, the router has no way of knowing that, and your router will be waiting forever for an IGP update about a certain route before sending it to external peers. You have to disable synchronization manually in this case for routing to work correctly:

router bgp 100
no synchronization

(Make sure you do a clear ip bgp address to reset the session.)



RTB#
router bgp 100
network 150.10.0.0
neighbor 1.1.1.2 remote−as 400
neighbor 3.3.3.3 remote−as 100
no synchronization
!−− RTB puts 170.10.0.0 in its IP routing table and advertises it to
!−− RTD even if it does not have an IGP path to 170.10.0.0)
RTD#
router bgp 400
neighbor 1.1.1.1 remote−as 100
network 175.10.0.0

RTA#
router bgp 100
network 150.10.0.0
neighbor 3.3.3.4 remote−as 100